jQuery 2.0不再支持IE6/7/8

Via http://liulanmi.com/news/5239.html

JQuery 2.0的发布象征着jQuery JavaScript库到了一个重要里程碑。2.0版本比前任版本在大小上缩减了12%,但是更值得注意的是,jQuery 2.0不再对IE6/7/8三个版本进行支持。

jQuery 2.0不再支持IE6/7/8

七年前jQuery的诞生,开始让开发者更简单的操作HTML和编写JavaScript,jQuery的跨浏览器特性,更是很快受到了广大开发者的青睐。根据去年的一项调查显示,粗略估计,网络上一半的站点都在使用jQuery。

停止对旧版IE的支持,是否会改变jQuery的使用率?答案也许是不会。如果你的网站需要维护对IE8或者低版本(或者是IE9和IE10在兼容模式下运行),你只需要沿用jQuery1.9或者以下版本。

“jQuery2.0主要用于现代网络,”jQuery的Dave Methvin在Query Foundation网站上写道,“我们有jQuery1.x版本处理旧版浏览器,并且期望他可以支持好几年。”

如果你想要同时兼容新旧版浏览器,你可以使用条件注释,让2.0在新浏览器上使用,而旧版本使用1.9,但是更简单的方法则是沿用jQuery1.x版本。至少目前2.0的主要用例,对IE的支持是不再考虑范围内了,而是Chrome或者Firefox的附加组件,PhoneGap应用程序或是node.js。

PS:你看看代码就知道我为了一个JQ2.0弄得多纠结。。

[C8500SROM] 【赖总的告别作】【DrLAB】2.3.7Final

明天就要去外地上课了,高中三年的开始。
有没有人注意到我的自定义头衔从初中生变成了准高中生又变成了高中生。
不知道以后还有没有空继续更新ROM了。
论坛里小昆走了,小枫走了,大侠去工作了。
还好还有大熊、企鹅大大坚守着。
希望以后在征得企鹅大大同意下,还有人能帮我同步下企鹅的底包,也希望有人能够用我的底包做ROM。
这期ROM没有实质性更新,只不过是更新了一些软件的新版本和一些问题的修复。
已知的BUG只有USB绑定了稳定性堪比官方

=密=封=线=内=不=准=答=题=

继续阅读 "[C8500SROM] 【赖总的告别作】【DrLAB】2.3.7Final" »